wphooks.info - auth_cookie_malformed

auth_cookie_malformed

(trunk - 5.0-alpha-43293)

The hook occurs in the following file:

wp-includes/pluggable.php:
603
604
605
606
607
608
609
610
611
612
613
614
615
616
617
618
619
620
621
		if ( ! $cookie_elements = wp_parse_auth_cookie( $cookie, $scheme ) ) {
			/**
			 * Fires if an authentication cookie is malformed.
			 *
			 * @since 2.7.0
			 *
			 * @param string $cookie Malformed auth cookie.
			 * @param string $scheme Authentication scheme. Values include 'auth', 'secure_auth',
			 *                       or 'logged_in'.
			 */
			do_action( 'auth_cookie_malformed', $cookie, $scheme );
			return false;
		}

		$scheme   = $cookie_elements['scheme'];
		$username = $cookie_elements['username'];
		$hmac     = $cookie_elements['hmac'];
		$token    = $cookie_elements['token'];
		$expired  = $expiration = $cookie_elements['expiration'];