wphooks.info - pre_option_enable_xmlrpc

pre_option_enable_xmlrpc

(trunk - 5.1-alpha-44286)

The hook occurs in the following file:

wp-includes/class-wp-xmlrpc-server.php:
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
	 *
	 * @param string $username User's username.
	 * @param string $password User's password.
	 * @return WP_User|bool WP_User object if authentication passed, false otherwise
	 */
	public function login( $username, $password ) {
		/*
		 * Respect old get_option() filters left for back-compat when the 'enable_xmlrpc'
		 * option was deprecated in 3.5.0. Use the 'xmlrpc_enabled' hook instead.
		 */
		$enabled = apply_filters( 'pre_option_enable_xmlrpc', false );
		if ( false === $enabled ) {
			$enabled = apply_filters( 'option_enable_xmlrpc', true );
		}

		/**
		 * Filters whether XML-RPC methods requiring authentication are enabled.
		 *
		 * Contrary to the way it's named, this filter does not control whether XML-RPC is *fully*
		 * enabled, rather, it only controls whether XML-RPC methods requiring authentication - such